Get your server issues fixed by our experts for a price starting at just 25 USD/Hour. Click here to register and open a ticket with us now!

Author Topic: Plesk (4.0)(pool) or Plesk (2.0)(pool) refusing to start.  (Read 1947 times)

0 Members and 1 Guest are viewing this topic.

akhils

  • Guest
Plesk (4.0)(pool) or Plesk (2.0)(pool) refusing to start.
« on: February 11, 2014, 12:58:38 pm »
Hi,

This is a common error which we come across with the Windows VPS with Plesk. While restarting a website under IIS, the dependant Plesk pool fails to start under the application pool.
--
Error in Event viewer: Application pool domain.tld(domain)(4.0)(pool) has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.
--

Resolution
To resolve the issue, perform the following steps:

1. Check which application pool serves the domain:

Go to IIS > Sites > domain.tld > Basic settings

2. Check the Identity that runs that application pool:

IIS > Application Pools > <name of the application pool> > Advanced settings > Process model: Identity

3. Reset the password for the account that runs the needed application pool:

Open the server management console > Configuration > Local Users and groups > Right-click <username> > Set password

4. Synchronize new settings for the Identity of the application pool:

IIS > Application Pools > <name of the application pool> > Advanced settings > Process model: Identity > "Browse" button (...) > "Set" button > Enter Identity account and newly set password

5. Recycle the application pool.
====

There by fixing the concern.  8)

Thank you for your time.  ;)