Get your server issues fixed by our experts for a price starting at just 25 USD/Hour. Click here to register and open a ticket with us now!

Author Topic: Plesk Error: The extension ‘.php’ may be incorrect  (Read 1988 times)

0 Members and 1 Guest are viewing this topic.

sajugovind

  • Guest
Plesk Error: The extension ‘.php’ may be incorrect
« on: December 14, 2013, 01:18:17 pm »
Some time after login into Plesk Control Panel if shows following error:

Server Error in '/' Application.
This type of page is not served.
Description: The type of page you have requested is not served because it has been explicitly forbidden. The extension '.php' may be incorrect. Please review the URL below and make sure that it is spelled correctly.

Requested Url: /index.php



The problem occurs when Plesk panel site is not properly configured IIS. To configure it again you will have to re-create the Plesk website in IIS by switching Plesk database provider to apache and then back to IIS. Following are the steps to re-create the Plesk website in IIS

1) Change the Plesk Web server fom IIS to Apache. This can be done using following command

C:ParallelsPleskadminbin>reconfigurator --switch-plesk-web-server --new-provider=apache


2) Run Plesk re-configurator to re-configure everything and wait till it finishes.

3) Switch the Plesk Web server back to IIS from Apache

C:ParallelsPleskadminbin>reconfigurator --switch-plesk-web-server --new-provider=iis


4) Run Plesk Re-configurator again.