Get your server issues fixed by our experts for a price starting at just 25 USD/Hour. Click here to register and open a ticket with us now!

Author Topic: Plesk Website Authentication Problem  (Read 3185 times)

0 Members and 1 Guest are viewing this topic.

vinayakk

  • Guest
Plesk Website Authentication Problem
« on: April 08, 2014, 10:44:10 pm »
Plesk Website Authentication Problem

You may get authentication pop ups in the website in Plesk is asking for user name and password

This is a common issue, but solutions varies based on situations. It could be one or a combination of a solutions listed below.

1. Permission issue was making the website to ask for the password. Run the Plesk permissions fix from the Plesk reconfigurator.

2. If it is asking for username and password, right after you changed the password of the account, 80% of the cases, below command based solution would work.
cd %plesk_bin%
websrvmng –update-anon-password –domain-name=domainname.com

3. Login to plesk, select the domain, click web directories. And there, select the the protection tab and click remove protection if enabled

4. Try resetting the domain password from Plesk, with Additional Write/Modify permissions checked. This may sync the IUSR_username’s password and the Plesk/FTP password. If it didn’t move on to next option to manually synchronize it.

5. Go to IIS > Web sites > domainname.com > Properties > Directory Security tab > Click on Edit button within “Authentication and access control” section > enter “password” in password filed > click OK.
After that, Go to Users Management > find user IUSR_pleskusername > Right Click > set password > proceed > enter “password” > click OK. If this also didn’t fix, issue is much more serious and move on to next options

6. Depending on the Plesk versions you use, Plesk group `psacln` should be allowed to access the server from the network. For that Go to, Administrative Tools > Security Settings > Local Polices > User Rights Assignment > Access this computer from the network

7. Check whether there is any new FTP accounts added with the “Home directory” as httpdocs itself. If so please remove it and then change the password at Domain Setup and save it
Check whether the plesk_username and IIS_pleskusername are added and has proper permissions for the DriveLetter:\Inetpub\vhosts\domainname.com as well as DriveLetter:\Inetpub\vhosts\domainname.com\httpdocs.

Try these are my current solutions. If you had to go through another solution to solve it, please add it over here for others.

 :) :)